Clicking Import graph from Table will open a wizard that will allow you to Import a Graph from a Table structured format. This involves selecting an input file, mapping columns of the input file to entities and creating links between entities. The information that defines a mapping is known as a mapping configuration and the wizard allows you to save and load existing mapping configurations.


Select a File

If you have multiple files with the same structure, then you can select multiple files to import at once.


First choose whether you want to create a new mapping configuration or load a saved one. By default, the most recent saved mapping configuration will be chosen.



Clicking the Manage button will bring up the Mapping Manager window which shows a table of all the currently saved mapping configurations. Mapping configurations are saved according to their name which must be unique. The name and description of a saved mapping configuration can be edited by clicking the edit icon (black arrow below). Mappings can also be deleted by clicking the corresponding delete icon (red arrow below).



After choosing a new or existing mapping configuration, choose the file to be imported and click on Next>.

Note: When loading a saved mapping configuration, Maltego will alert you if the selected mapping is not compatible with the data-file selected.


Connectivity Options

Select how you would like your imported items to be connected.



The different options are:

  • Meshed: All entities are connected to each other.
  • Sequential: Each entity is connected to the previous one in the order of the columns.
  • Tree: All entities are connected to the first entity.
  • Manual: No links are automatically created.


Mapping Configuration

In this step the user is presented with four tabs which separate mapping configuration creation into four logical processes. At least one entity needs to be defined in the Map Columns to Entities tab, and for two or more defined entities you can create and edit links between them (Connectivity Table tab) and/or assign link properties to input file columns (Map Columns to Links tab).


Note: If a saved mapping configuration was chosen in the Select File step, the entities, links and column mappings would be pre-configured for this step.


Map Columns to Entities Tab

Entity mapping is performed by completing three steps for each entity that will be mapped.



You can tell Maltego to treat the first row of the data differently to the rest.

  • Row is Headers: Don't use the row's data when importing
  • Row is Types: The row contains the entity type for that column. E.g. maltego.Person


Select one or more ‘unmapped’ columns , then the entity to which the selected columns are mapped must be selected from the Map to list.


Tip: To add or remove a column from the selected entity hold down Ctrl and click on the column.



Once an entity has been chosen, the property to which each column maps can be edited in step 3.



Steps 1 to 3 are repeated for each entity that should be mapped.


Connectivity Graph Tab

Maltego will automatically generate links between newly mapped entities in the Map Columns to Entities tab. These can be viewed and deleted or additional links can be created in the Connectivity Graph Tab. Create new links by clicking on one entity and dragging your mouse to another.


Tip: Multiple links can be selected by holding down Ctrl or Alt and dragging the mouse across the graph to create a selection box.


Connectivity Table

The Connectivity Graph and Connectivity table are both used to define the relationships between imported entities. The connectivity table, provides a table of check-boxes. The check-boxes can be checked and unchecked to create relationships between the entities.


The results of any changes made in the Connectivity Table can be viewed in the Connectivity Graph and visa versa.



Map Columns to Links Tab

The steps for mapping columns to links are the same as the steps for mapping columns to entities, the only difference being that the Map to combo box will present the list of links (created in the Connectivity Graph/Table tab) as opposed to entities.



Settings

After the mapping configuration, has been defined, the wizard presents a Settings screen where various tabular import settings can be set such as sampling, empty values, graph size and link merging. 


If a current graph exists, you will have the option to merge the imported graph with it. 


You are also given the option to save the mapping configuration (checked by default) with a default name and description. Mapping configurations are saved with a non-empty, unique name. If the entered name is not unique the existing mapping configuration will be overwritten but a warning will be shown in such cases.


If you choose not to save the mapping configuration, Maltego will save it automatically as Auto-saved mapping — overwriting the existing auto-saved mapping configuration if it exists.


Note: When the Auto-saved mapping is loaded in the Select File step, the default name will be blank forcing you to define a more descriptive name.



Import

If the import has failed, the wizard will inform you and give as much information as possible about the problem. If the import completed successfully a summary of the import result is presented which include the name under which the mapping configuration has been saved.