In order to run Maltego you will need a 64-bit version of the Java 8 (JRE)- Java Runtime Environment.


Instructions for installing JRE 8 on your machine, can be found here.


How to configure Maltego if multiple versions of Java is installed: How do I configure the version of Java used by Maltego?